vue 问题

vue-cli旧版本卸载不了

#### 1.$npm uninstall vue-cli -g      //卸载vue-cli旧版本</br>
#### 2.$npm install -g @vue/cli      //安装新版本</br>
#### 3.$npm vue -V                  //2.9.6,我差,根本没删除掉!</br>

原因

root@default:/usr/local/lib/node_modules# ls
@vue  cnpm  npm  vue-cli

没找到合适的方法就直接删掉旧版本的vue-cli

vue create 速度太慢而且会失败

https://blog.csdn.net/u013483969/article/details/98209971

修改.vuerc文件,如果是是要使用淘宝镜像源那么就要将 "useTaobaoRegistry" 改成 true,我现在不想使用那么我就将 "useTaobaoRegistry" 改成 false

vim ~/.vuerc

原因是项目放在了docker挂载的共享目录下,权限不够,直接放在docker自己目录下即可

Cannot find module ‘./index.vue?vue&type=style&index=0&lang=scss&’

原因: 普通的style标签只支持普通样式

解决:

npm install node-sass@4.13.0
npm install sass-loader@7.3.1

评论

Your browser is out-of-date!

Update your browser to view this website correctly. Update my browser now

×